Tag Archives: libgcrypt – issue with cpanel upgrade

Issue with cPanel upgrade – giflib, libxslt, libxslt-devel dependency errors !

When trying to upgrade cPanel to a latest version, do you find this error ?

You could try using --skip-broken to work around the problem You could try running: package-cleanup --problems The program package-cleanup is found in the yum-utils package.
The system failed to execute yum with the arguments â-y -c /etc/yum.conf install giflib libxslt libxslt-devel zshâ/usr/bin/yumâEPERMâ
E Sysup: Needed system RPMs were not installed: giflib, libxslt, libxslt-devel, zsh

The issue is, the package manager is searching for an incorrect version of the libgcrypt-devel package.

Fix this error by giving the following :

# rpm --rebuilddb
# yum clean all
# yum install libxslt libxslt-devel zsh

Once this is complete, re-run the upgrade. Even after this, you get an issue with dependency of the package – libgcrypt, remove it using yum and run # /scripts/upcp.

cPanel update will look after the dependencies and install libgcrypt too.