Tag Archives: collect2: ld returned 1 exit status make: *** [sapi/cli/php] Error 1

EasyApache failing to rebuild ? -Part 1

Is EasyApache failing to rebuild Apache/PHP with the following error codes ?

ext/pcre/php_pcre.o: In function `pcre_get_compiled_regex':
php_pcre.c:(.text+0x31b): undefined reference to `pcre_info'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1
!! Step 6: make php for apache and cli !!
!! 'make -j2' failed with exit code '512' !!
!! Restoring original working apache !!
!! Executing '/usr/local/cpanel/scripts/initsslhttpd' !!

You can check if this is the case by tail’ng the last logs from /usr/local/cpanel/logs/easy/apache/

If the error relates to the above, it means that the pcre version installed isn’t compatible with the specific version of PHP, this can be very true if you have any custom mods like PHP 4.4.9 or so installed along with the 5.x versions.

To get around this error, remove the PHP 4.4.x support and recompile Apache/PHP via EasyApache, which should work fine.